Difference between revisions of "8.40.4"

From cchtml.com
Jump to: navigation, search
(Other Information)
m (Protected "8.40.4": Excessive vandalism (‎[edit=autoconfirmed] (indefinite) ‎[move=autoconfirmed] (indefinite)))
 
(One intermediate revision by the same user not shown)
Line 25: Line 25:
 
* [http://ati.amd.com/products/catalyst/linux.html ATI Proprietary Linux Driver FAQ]
 
* [http://ati.amd.com/products/catalyst/linux.html ATI Proprietary Linux Driver FAQ]
  
It was a excitement lnoaticg your site yesterday. I came here right hoping to learn something new. And I was not dissatisfied. Your well thought out ideas for new events like this. Thank you for this idea and sharing your knowledge.
+
=Other Information=
 +
== Symptom ==
 +
 
 +
Kernel 2.6.21 : the kernel module fglrx.ko will not be built ... and the ATI installer wont tell you, it has not.
 +
 
 +
Kernel 2.6.22 will compile the module.
 +
 
 +
==  Reason ==
 +
 
 +
ATI kernel module has non-GPL License. Kernel build system has restricted the usage of some functions to GPL-only modules. So the kernel module won't be compile.
 +
 
 +
== Solution ==
 +
 
 +
a) Go kick ATI to build a GPL compatible kernel module.
 +
 
 +
b) Modify the MODULE_LICENSE String in the kernel module to "GPL"
 +
 
 +
- or -
 +
 
 +
Upgrade to Kernel >2.6.22
 +
[[Category:Releases]]

Latest revision as of 00:21, 17 March 2013

ATI Linux fglrx driver version 8.40.4

Release Date: 13 August, 2007

New Features

  • TV Out Functionality
  • Catalyst Control Center Linux Edition

Issues Resolved

  • A black screen is no longer observed on some hardware when switching to the console or leaving the X window system when a Vesa framebuffer console driver is used. Further details can be found in topic number 737-28558
  • Connecting a component Video display device launching X-Server no longer results in X-Server failing to start and the display device displaying a black screen. Further details can be found in topic number 737-28846
  • The DRI no longer fails to initialize in the second server generation. Further details can be found in topic number 737-28847
  • Pressing the identify displays function no longer results in display device 1 and 2 being incorrectly identified. Further details can be found in topic number 737-28848
  • A Floating Point Exception error no longer occurs when launching amdcccle. Further details can be found in topic number 737-28849

Known Issues

  • Corruption may be observed with certain applications on some Linux distributions which enable the Composite extension by default, e.g., RHEL 5. If you are observing application corruption, please disable the Composite extension. Further details can be found in topic number 737-28224
  • Using the xgl enabled x-server interface disables display switching hot plug support
  • There is no support for video playback on the second head in dual head mode. Further details can be found in topic number 737-26985

External links

Other Information

Symptom

Kernel 2.6.21 : the kernel module fglrx.ko will not be built ... and the ATI installer wont tell you, it has not.

Kernel 2.6.22 will compile the module.

Reason

ATI kernel module has non-GPL License. Kernel build system has restricted the usage of some functions to GPL-only modules. So the kernel module won't be compile.

Solution

a) Go kick ATI to build a GPL compatible kernel module.

b) Modify the MODULE_LICENSE String in the kernel module to "GPL"

- or -

Upgrade to Kernel >2.6.22