Difference between revisions of "Arch Linux"

From cchtml.com
Jump to: navigation, search
(Stock Kernels)
(Before you start)
Line 8: Line 8:
  
 
===Before you start===
 
===Before you start===
Install the necessary programs
+
You'll need to install the necessary programs
 
{{Box Terminal|
 
{{Box Terminal|
 
<nowiki>#</nowiki> pacman -S xorg hwd<br />
 
<nowiki>#</nowiki> pacman -S xorg hwd<br />

Revision as of 09:20, 15 May 2009

Installing and using fglrx drivers on Arch Linux should be a piece of cake, as the distro provides pre-built packages in its official repos, accessible through the pacman package manager.

The installation instructions I've taken straight from Arch's own wiki page, linked below in the External Resources section.

Contents

Installation

Before you start

You'll need to install the necessary programs

Terminal Command

# pacman -S xorg hwd
# hwd -xa
# pacman -S xf86-input-evdev
# pacman -S xf86-input-mouse
# pacman -S xf86-input-keyboard
# /etc/rc.d/hal start
# pacman -Rd libgl


Terminal Command

# yaourt -Sy catalyst catalyst-utils
# aticonfig --initial


Notes

  • These packages contain only the kernel module, and depend on the catalyst-utils package. The catalyst-utils package is kernel-independent and provides the libraries and utilities for Xorg, including ATI's own libGL.so.
  • After installing the package, you'll need to either source /etc/profile or log out, then back in to set up the environment properly.
  • If you run both kernel26 and kernel26beyond then install both catalyst module packages. They won't conflict with one another.

Custom Kernels

To install catalyst for a custom kernel, you'll need to build your own catalyst-$kernel package, containing the kernel module compiled specifically for your kernel.

If you are at all uncomfortable or inexperienced making packages, read up Arch's ABS wiki page first so things go smoothly.

Obtaining PKGBUILD

Obtain the PKGBUILD and catalyst.install files from CVS or ABS. Either:

Editing the PKGBUILD and building

Three changes need to be made here:

First, change

   pkgname=catalyst

to

   pkgname=catalyst-KERNEL_NAME

where KERNEL_NAME is whatever you want (custom, mm, themostawesomekernelever)

Second, remove kernel26 from the dependencies list.

Third, change

   _kernver=2.6.15-ARCH

to

   _kernver=`uname -r`

(or directly insert the output of uname -r when running your custom kernel there)

Finally, build and install the package. (makepkg -i or makepkg followed by pacman -A pkgname.pkg.tar.gz)

Notes

  • No changes need to be made to the catalyst-utils package, which is completely kernel-independent. All you need to do is compile a kernel module.
  • To build and run the catalyst kernel module with 2.6.16 kernels, patches are needed! Check out the cvs entries for catalyst in testing for the required patch.

Related Resources


Distribution Neutral Steps

Verifying | Configuring | Troubleshooting