Debian Installation Guide

From cchtml.com
Revision as of 05:48, 29 January 2010 by 24.22.119.221 (Talk)

Jump to: navigation, search

2007-11, see http://wiki.debian.org/AtiHowTo


As of November 2005, ATI's drivers are in the non-free area of Debian. Make sure your /etc/apt/sources.list contains "contrib non-free" as well as main. You will, however, have to build your own kernel modules.

Warning: do not mix the non-free packages with the packages created by the installer as they will conflict in non-obvious ways. Before switching from one method to another, completely remove all fglrx-related packages. Never do upgrade from one method to another directly!


comment1,

comment6,

Update the xorg.conf file (Configuration)

sudo aticonfig --initial

Now restart X, or reboot for the driver changes to take effect.


wtf is 'comment 1' and 'comment 6'?

Confirm that it worked

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9700 Generic
OpenGL version string: 1.3.5461 (X4.3.0-8.19.10)

If it didn't work, you may need to run:

# mkdir -p /usr/X11R6/lib/modules/dri
# ln -s /usr/lib/dri/fglrx_dri.so /usr/X11R6/lib/modules/dri

Thanks to Maciej Matysiak for the clear debug here and solution here.

If it's still not working, try:

# rm /usr/lib/libGL.so*
# rm /usr/X11R6/lib/libGL.so*
# cd /usr/X11R6/lib
# cp /usr/lib/fglrx/diversions/lib/libGL.so.1.2 .
# ln -s libGL.so.1.2 libGL.so.1
# ldconfig

and confirm that 'ldd /usr/bin/fglrxinfo' is pointing to the right one.


People seem to be experiencing a broken libGL.so.1 after installing 8.41 on Debian/etch. If `amdcccle` complains that libGL.so.1 does't exist, DONT DELETE /usr/lib/libGL.so.1.2 LIKE IT SAYS ABOVE. Make symbolic link to libGL.so.1.2 (which is included in fglrx package - 14 megs in size):

# cd /usr/lib
# ln -s libGL.so.1.2 libGL.so.1

This work fine for ATI mobility radeon 1400

(make backup the olds xorg.* files in your folder)

$ cp /etc/X11/xorg.conf /home/username/xorg.conf.old
$ cp /var/log/Xorg.0.log /home/username/Xorg.0.log.old

(add contrib non-free in repositories)

$ apt-get update
$ apt-get install module-assistant build-essential fakeroot dh-make debconf bzip2

(from www.amd.com download the courent version of driver for your ATI)

$ sh ./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg Debian/lenny
$ apt-get install fglrx-amdcccle_8.40.4-1_i386.deb
$ apt-get install fglrx-driver-_8.40.4-1_i386.deb
$ apt-get install fglrx-driver-dev_8.40.4-1_i386.deb
$ apt-get install fglrx-kernel-src_8.40.4-1_i386.deb
$ apt-get -f upgrade
$ apt-get update


$ module-assistant prepare
$ module-assistant update
$ module-assistant a-i fglrx
$ aticonfig --initial

(reboot computer)

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9700 Generic
OpenGL version string: 1.3.5461 (X4.3.0-8.19.10)