Difference between revisions of "Fedora 8 Installation Guide"

From cchtml.com
Jump to: navigation, search
(Installation from Livna repository)
(add freshrpms)
Line 3: Line 3:
 
* Unfortunately the driver kernel module currently fails to compile since Linux kernel version 2.6.23 is not yet supported. See this [http://ati.cchtml.com/show_bug.cgi?id=803 bugzilla report for kernel 2.6.23] for more information.
 
* Unfortunately the driver kernel module currently fails to compile since Linux kernel version 2.6.23 is not yet supported. See this [http://ati.cchtml.com/show_bug.cgi?id=803 bugzilla report for kernel 2.6.23] for more information.
  
==Installation from Livna repository==
+
==Installation Option #1 Freshrpms.net repository==
 +
rpm -ihv http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/8/freshrpms-release/freshrpms-release-1.1-1.fc.noarch.rpm
 +
yum install -y ati-x11-drv
 +
and restart your system.
 +
 
 +
==Installation Option #2 Livna repository==
 
  rpm -ivh http://rpm.livna.org/livna-release-8.rpm
 
  rpm -ivh http://rpm.livna.org/livna-release-8.rpm
 
  yum install -y kmod-fglrx
 
  yum install -y kmod-fglrx
 
and restart your system.
 
and restart your system.
  
==Installation via ATI Installer==
+
==Installation Option #3 via ATI Installer==
 
The above bugzilla contains a patch to the firegl module source code. Here is an annotated walk-through for those not familiar with using the patch utility:
 
The above bugzilla contains a patch to the firegl module source code. Here is an annotated walk-through for those not familiar with using the patch utility:
 
* Install the driver interactively
 
* Install the driver interactively

Revision as of 12:19, 14 November 2007

General Status

  • Fedora 8 is included as a generatable package since version 8.42.3 of the AMD Proprietary Linux driver. "sh ati-driver-installer-8.42.3-x86.x86_64.run --listpkg | grep -i fedora" shows "Fedora/F8" in the output.
  • Unfortunately the driver kernel module currently fails to compile since Linux kernel version 2.6.23 is not yet supported. See this bugzilla report for kernel 2.6.23 for more information.

Installation Option #1 Freshrpms.net repository

rpm -ihv http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/8/freshrpms-release/freshrpms-release-1.1-1.fc.noarch.rpm
yum install -y ati-x11-drv

and restart your system.

Installation Option #2 Livna repository

rpm -ivh http://rpm.livna.org/livna-release-8.rpm
yum install -y kmod-fglrx

and restart your system.

Installation Option #3 via ATI Installer

The above bugzilla contains a patch to the firegl module source code. Here is an annotated walk-through for those not familiar with using the patch utility:

  • Install the driver interactively
sh ati-driver-installer-8.42.3-x86.x86_64.run
  • Backup the existing module, download the patch
cd /lib/modules/fglrx/build_mod/
cp firegl_public.c firegl_public.c.orig
wget -qO- http://ati.cchtml.com/attachment.cgi?id=466 > firegl.patch
  • Apply the patch
patch -p0 < firegl.patch
  • Now build and install the kernel module
./make.sh
cd .. ; ./make_install.sh
  • Create an initial X Server configuration file
aticonfig --initial
  • Restart your X Server (by logging in/out or rebooting)

Other Issues

FYI: this patch (and others like it) is incomplete. It fails miserably with the drm module loaded. It will not work without drm either, and what would be the point? As seen by dmesg:

[drm] Initialized drm 1.1.0 20060810 [fglrx] Maximum main memory to use for locked dma buffers: 1898 MBytes. [fglrx] ASYNCIO init succeed! [fglrx:KCL_enable_pat] *ERROR* Pat entry 2 is already configured [fglrx] PAT is disabled! [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed

The livna rpm incurs the same failure. Stick with F7 and kernel 2.6.22, or use the radeon driver instead.

See Also