Difference between revisions of "Frequently Asked Questions"

From cchtml.com
Jump to: navigation, search
m (Protected "Frequently Asked Questions": Excessive vandalism ([edit=autoconfirmed] (expires 14:15, 10 January 2013 (UTC)) [move=autoconfirmed] (expires 14:15, 10 January 2013 (UTC))))
(Undo revision 916 by Mooninite (talk))
Line 1: Line 1:
==Installation==
+
Hello!I'm having promelbs installing ati on my vaio vgn-s1xpwhith a radeon 9700.In fglrxinfo it gives me this:Xlib: extension  XFree86-DRI  missing on display  :0.0 When I turn composites off, I thik the dri loads, but I only get a black screen! Have to turn composites on again to be able to use ubunto (6.10).Any help would be apreciated!Thanks in advance!
===How do I know fglrx is installed correctly?===
+
There are several ways to check if fglrx is loaded and running.
+
<br>1. Check your X.org or XFree86 log. You should see "DRI Initialization Successful."
+
  # less /var/log/Xorg.0.log
+
or
+
# less /var/log/XFree86.0.log
+
2. Check glxinfo. You should see "direct" and not "indirect."
+
# glxinfo | grep direct
+
3. Check your kernel log. You should see fglrx messages near the bottom.
+
# dmesg
+
4. Check your modules. You should see fglrx loaded.
+
# lsmod | grep fglrx
+
*NOTE: [[Glxgears is not a Benchmark|glxgears]] is not a definite way of checking the installation of fglrx.
+
 
+
=== Is the rebooting really necessary? ===
+
 
+
No.
+
 
+
However, rebooting is the easiest method to ensure that the kernel module(s) from the old driver are unloaded and the fglrx module is loaded instead. If you don't want to reboot for some reason, you may manually shut down Xorg, unload any old "drm", "radeon" or "fglrx" modules and then start Xorg again.
+
 
+
==Kernel==
+
===Why does fglrx not work for my kernel?===
+
The development process of the fglrx driver and the Linux kernel are not on the same level.  The fglrx driver requires some special interactions with the kernel memory API and these tend to change between kernel versions.
+
 
+
There is also an 11-12 week cycle required to develop, validate and test each release of an ATI driver <ref>http://www.phoronix.com/scan.php?page=article&item=735&num=1</ref>.  ATI will only look to support the latest kernel that is officially out (no -rc or -git releases are supported) at the time they release a driver. Example: fglrx version A comes out Monday, but kernel version B comes out Tuesday. Kernel version B is not supported by fglrx version A. (but might be able to work anyway by doing a 'modprobe -f fglrx' in a shell)
+
 
+
The binary part of ATI's kernel module has no explicit dependency on the Linux kernel.  There are a set of source files that provide the glue to the kernel.  This is where the dependency to different kernels exist.  As a result, user contributed patches for newer kernels can often be found by searching [http://ati.cchtml.com Bugzilla].
+
 
+
Note: That's why an opensource hardware driver is necessary. Hopefully, AMD will continue releasing more documentation and we will be able to code our own maintainable and free driver, thus freeing ourselves from this dependency on AMD's good will - and freeing AMD to focus on hardware.
+
 
+
==X Configuration==
+
===How do I configure my system to use the fglrx driver?===
+
*aticonfig
+
:Command line program to modify the /etc/X11/xorg.conf file.
+
*amdcccle
+
:GUI program that allows detailed configuration over the driver's controls.
+
*/etc/X11/xorg.conf
+
:X configuration file. Find the Device section for your ATI card and edit the Driver line to read
+
Driver "fglrx"
+
:Note: This is the least-preferred method. Many things can stop working.
+
 
+
==Troubleshooting==
+
* See [[Troubleshooting]] page.
+
 
+
==See Also==
+
*[http://ati.amd.com/products/catalyst/linux.html Official ATI Linux Driver FAQ]
+
 
+
==References==
+
<references/>
+

Revision as of 13:03, 4 July 2013

Hello!I'm having promelbs installing ati on my vaio vgn-s1xpwhith a radeon 9700.In fglrxinfo it gives me this:Xlib: extension XFree86-DRI missing on display  :0.0 When I turn composites off, I thik the dri loads, but I only get a black screen! Have to turn composites on again to be able to use ubunto (6.10).Any help would be apreciated!Thanks in advance!