Difference between revisions of "Gentoo Version Limitations"

From cchtml.com
Jump to: navigation, search
(New page: Here's a list of the currently rather annoying limitations of the Gentoo ati-drivers ebuilds. Will be updated as my experimenting goes along... ~~~ {| border="1" | ebuild || driver versi...)
 
 
Line 1: Line 1:
 
Here's a list of the currently rather annoying limitations of the Gentoo ati-drivers ebuilds. Will be updated as my experimenting goes along... [[User:Akhuettel|Akhuettel]]
 
Here's a list of the currently rather annoying limitations of the Gentoo ati-drivers ebuilds. Will be updated as my experimenting goes along... [[User:Akhuettel|Akhuettel]]
  
 +
Kernel required parameters
 +
 +
- present MTRR
 +
- present AGP/PCIEPORTBUS
 +
- present ACPI
 +
- present MAGIC_SYSRQ
 +
- present PCI_MSI
 +
- present LOCKDEP
 +
- ! present PREEMPT_RCU if > 2.6.25
 +
- ! builtin DRM
  
 
{| border="1"
 
{| border="1"
 
| ebuild || driver version || x86    || amd64  || required kernel version || required X version  
 
| ebuild || driver version || x86    || amd64  || required kernel version || required X version  
 
|-
 
|-
| 8.501  || [[8.6]]            || stable || testing || <= 2.6.25-gentoo-r7 OK, does not compile with 2.6.26-gentoo-r4  || ?
+
| 8.501  || [[8.6]]            || removed || removed || <= 2.6.25-gentoo-r7 OK, does not compile with 2.6.26-gentoo-r4  || ?
 +
|-
 +
|  8.552-r2 || [[8.11]]        || masked || masked || ?                      || >=x11-base/xorg-server-1.5
 +
|-
 +
| 9.11 || [[9.11]]        || stable || stable || =2.6                ||!>=x11-base/xorg-server-1.7.0<br>>=x11-base/xorg-server-1.5.3-r7
 +
|-
 +
| 10.3 || [[10.3]]        || testing || testing || =2.6              ||!>=x11-base/xorg-server-1.7.0<br>>=x11-base/xorg-server-1.5.3-r7
 
|-
 
|-
| 8.552-r2 || [[8.11]]        || testing || testing || ?                      || >=x11-base/xorg-server-1.5
+
| 10.4 || [[10.4]]        || testing || testing || =2.6                ||!>=x11-base/xorg-server-1.8.0<br>!<x11-base/xorg-server-1.7
 
|}
 
|}

Latest revision as of 05:14, 13 May 2010

Here's a list of the currently rather annoying limitations of the Gentoo ati-drivers ebuilds. Will be updated as my experimenting goes along... Akhuettel

Kernel required parameters

- present MTRR - present AGP/PCIEPORTBUS - present ACPI - present MAGIC_SYSRQ - present PCI_MSI - present LOCKDEP - ! present PREEMPT_RCU if > 2.6.25 - ! builtin DRM

ebuild driver version x86 amd64 required kernel version required X version
8.501 8.6 removed removed <= 2.6.25-gentoo-r7 OK, does not compile with 2.6.26-gentoo-r4  ?
8.552-r2 8.11 masked masked  ? >=x11-base/xorg-server-1.5
9.11 9.11 stable stable =2.6 !>=x11-base/xorg-server-1.7.0
>=x11-base/xorg-server-1.5.3-r7
10.3 10.3 testing testing =2.6 !>=x11-base/xorg-server-1.7.0
>=x11-base/xorg-server-1.5.3-r7
10.4 10.4 testing testing =2.6 !>=x11-base/xorg-server-1.8.0
!<x11-base/xorg-server-1.7