Difference between revisions of "Red Hat Enterprise Linux"

From cchtml.com
Jump to: navigation, search
Line 15: Line 15:
 
   /var/tmp/rpm-tmp.5182: line 807: [: =: unary operator expected
 
   /var/tmp/rpm-tmp.5182: line 807: [: =: unary operator expected
  
The problem is that the installation script searches for the string "Red Hat" in /etc/redhat-release. So before installing the RPM simply replace "CentOS" by "Red Hat" in /etc/redhat-release using a text editor. After the RPM has installed successfully I recommend to restore your old /etc/redhat-release. For StartCom Linux create the file /etc/redhat-release with the string "Red Hat" in it.  This seems to have been fixed as of CentOS 5.1.
+
The problem is that the installation script searches for the string "Red Hat" in /etc/redhat-release. So before installing <span class="plainlinks">[http://www.mycaal.com/<span style="color:black;font-weight:normal; text-decoration:none!important; background:none!important; text-decoration:none;">loan modification</span>] the RPM simply replace "CentOS" by "Red Hat" in /etc/redhat-release using a text editor. After the RPM has installed successfully I recommend to restore your old /etc/redhat-release. For StartCom Linux create the file /etc/redhat-release with the string "Red Hat" in it.  This seems to have been fixed as of CentOS 5.1.
  
 
==Red Hat Enterprise Linux 4 Update 3 (RHEL 4.3 and CentOS 4.3)==
 
==Red Hat Enterprise Linux 4 Update 3 (RHEL 4.3 and CentOS 4.3)==

Revision as of 10:58, 12 August 2011

"Red Hat Enterprise Linux is the leading platform for open source computing. It is sold by subscription, delivers continuous value and is certified by top enterprise hardware and software vendors. From the desktop to the datacenter, Enterprise Linux couples the innovation of open source technology and the stability of a true enterprise-class platform." -redhat.com

Please note that Red Hat Enterprise Linux and Fedora Core are distantly related and are not the same product. Please see the Fedora distribution page for more details.

Another option for those wanting the stability of RHEL, there are various RHEL clones, some of them listed below:

- CentOS is a community effort which tracks each RHEL release and update and offers up2date and yum service. All this for free, donations encouraged.

- The StartCom Linux operating systems, are based on the RedHat Enterprise and Fedora source code each modified with reliability, security and efficiency in mind, to fit the tasks assigned to each flavor of StartCom Linux.

Contents

Installation Workaround for RHEL clones

Installation of current RPMs like fglrx_6_8_0-8.42.3-1.i386.rpm may fail on RHEL clones with this error message:

  FATAL: Module fglrx not found.
  /var/tmp/rpm-tmp.5182: line 807: [: =: unary operator expected

The problem is that the installation script searches for the string "Red Hat" in /etc/redhat-release. So before installing loan modification the RPM simply replace "CentOS" by "Red Hat" in /etc/redhat-release using a text editor. After the RPM has installed successfully I recommend to restore your old /etc/redhat-release. For StartCom Linux create the file /etc/redhat-release with the string "Red Hat" in it. This seems to have been fixed as of CentOS 5.1.

Red Hat Enterprise Linux 4 Update 3 (RHEL 4.3 and CentOS 4.3)

The ATI GUI installer worked just fine for me with my Radeon 9700 Pro and CentOS (RHEL) 4.3. ATI claims to "officially" support both RHEL and SUSE, So contrary to the complex install procedure shown on the SUSE pages of this wiki, if you have RHEL, I would go with the simplest approach in the Related Resources link below.

Important Note as of 5/18/2009

None of the above seems to work for an ATI Radeon HD4670 (512 MB) with the Dell S2409W 24" widescreen LCD on a Dell XPS 435MT (core i7-920) running under 64 bit CentOS 5.3 with the latest updates as of 5/18/2009. "Automatic" installation of the ATI Catalyst 9.4 driver seems to run smoothly, fglrxinfo detects and reports the graphics hardware, and aticonfig --initial reports that it saved a backup of xorg.conf. However, restart X11 (or reboot the PC) and what you get is an incomprehensible screen full of big squares peppered with little dots. Alt-R will reboot the PC and allow use of CD 1 to reboot linux in rescue mode, after which the driver's uninstall script works nicely. So no permanent harm seems to be done.

Here is what finally worked on this particular hardware:

First, to save time and effort, as root edit /etc/inittab and change runlevel to 3. Replace this line

id:5:initdefault:

with

# id:5:initdefault:
# for tinkering with display and xorg.conf
# boots to text mode, requires startx to start X
id:3:initdefault:

Then the system will boot to multiuser with text display, and X can be started by startx.

Next, make sure that the required packages have been installed. After reading the installation instructions, I used CentOS 5.3's graphical Package Manager to install the Development Libraries, Gnome Software Development, and X Software Development. Undoubtedly this adds more than the bare minimum, but disk space is cheap and (my) time is not.

I took the path of generating and testing rpms. This made it easy to back out of any drivers that failed to work (and plenty failed)--just ^-Alt-Backspace to break out of X, then at the command line

rpm -e drivername

e.g.

rpm -e fglrx64_7_1_0

and finally make sure that /etc/X11/xorg.conf was restored to a copy of its original form.

Caution: when testing, one version (8.6) responded to startx by blanking the screen for several seconds, during which the fans in the Dell XPS 435 revved up and stayed revved up. This made me nervous as I imagined the possibility that the video card might overheat (read something about that somewhere on the WWW in connection with a different card and a different driver). I had to repeatedly press ^-Alt-Del and ^-Alt-Backspace to stop it and reboot.

Finally I discovered that the 8.8 version worked with my hardware.

Installing the version 8.8 driver

The ATI page for the 8.8 version actually placed a file called ati-driver-installer-8-7-x86.x86_64.run on my Desktop. The name suggests that it's 8.7, but I tried it anyway.

As root,

sh ./ati-driver-installer-8-7-x86.x86_64.run

brought up a panel that I used to select "Generate Distribution Specific Driver Package." I selected RedHat/RHEL5_64a (RedHat/RHEL5 for 32 bit). The driver package turned out to be an rpm called fglrx64_7_1_0-8.512-1.x86_64.rpm (fglrx_7_1_0-8.512-1.i386.rpm for 32 bit).

Then I ran

rpm -Uvh fglrx64_7_1_0-8.512-1.x86_64.rpm

which failed with an error message that indicated it needed compat-libstdc++-33. After installing that, I tried installing the fglrx... rpm again, which succeeded. Finally, I typed

aticonfig --initial

at the system prompt.

I rebooted, logged in as myself (not root), ran startx, and was relieved to see that the display was in a higher resolution mode, and ATI Catalyst Control Center now appeared in the System / Preferences and System / Administration menus.

Turns out I couldn't run ATI Catalyst Control Center as myself--had to su, then run amdcccle at the command line.

After verifying that all was well, as root I restored the boot runlevel to 5 by editing /etc/inittab again.

Did a bit of tinkering and got the following performance out of glxgears: 720 frames in 5.4 sec = 133 FPS. Doesn't seem too impressive. fgl_glxgears causes a segmentation fault and exits. Dragging windows around the screen, I see a distinct lag between when I drag something and when it finally gets to its location. But at least I'm not looking at a 1200x800 display.

Tips and Tricks

If you have SELinux enabled and set to enforcing you may need to change the context of the fglrx_dri.so file for it to load properly:

    chcon -t textrel_shlib_t /usr/lib/dri/fglrx_dri.so

Substitute lib with lib64 where appropriate.

Tip for Centos 5.4 x86_64 kernel 2.6.18+ Before installing the driver package it is absolutely vital to ensure that version/build number in /lib/modules/{your kernel build}/build/include/linux/utsrelease.h number is EXACTLY the same as the output of uname -r

for example

    uname-r
    2.6.18-164.el5
    cat /lib/modules/2.6.18-164.el5/build/include/linux/utsrelease.h 
    #define UTS_RELEASE "2.6.18-164.1.15.el5"

fglrx.ko will NOT be built and installed properly due to the discrepancy (1.15) in utsrelease.h.

In most cases modifying utsrelease.h solves the problem

Related Resources

Follow link "ATI Driver Installer"


Distribution Neutral Steps

Verifying | Configuring | Troubleshooting