Changes

Jump to: navigation, search

Ubuntu Quantal Installation Guide

827 bytes added, 08:02, 23 February 2013
Using the xvba-va Driver (VA-API)
Install the prerequisite packages:
sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-genericfakeroot
''If you are using the x86_64 architecture (64 bit)'':
===''Download the latest Catalyst package.''===
This package contains both the 32-bit and 64-bit driver.
 
Note that the file name may change to version 13.2 please change the file name as needed in case you get "not found" errors.
Also note that -linux- and -beta3- may change as well. This can be confusing.
wget http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-13.1-linux-x86.x86_64.zip
Install the prerequisite packages:
sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-genericfakeroot
''If you are using the x86_64 architecture (64 bit)'':
sudo apt-get install lib32gcc1
===''Download the latest Catalyst package.''===
This package contains both the 32-bit and 64-bit driver.
wget http://www2.ati.com/drivers/beta/amd-driver-installer-catalyst-1213.112-beta11beta6-linux-x86.x86_64.zip unzip amd-driver-installer-catalyst-1213.112-beta11beta6-linux-x86.x86_64.zip chmod +x amd-driver-installer-catalyst-1213.112-beta6-beta11linux-x86.x86_64.run
===''Create and install .deb packages.'' ===
sudo sh ./amd-driver-installer-catalyst-1213.112-beta11beta6-linux-x86.x86_64.run --buildpkg Ubuntu/quantal
sudo dpkg -i fglrx*.deb
Once you've confirmed that vainfo is correct, you can test video playback. A good test player for va-api is VLC. You can enable va-api in Tools -> Preferences -> Input and Codecs. Check the box named "Use GPU acceleration (experimental)" and then restart VLC.
 
 
== Other ==
There is possibility to enable > H.264 Level 5.1 decoding in the driver which "has been in the driver for some time but not enabled by default"
 
sudo amdconfig --set-pcs-u32=MCIL,HWUVD_H264Level51Support,1
 
or
 
sudo service lightdm stop
sudo cp -p /etc/ati/amdpcsdb /etc/ati/amdpcsdb.bak
sudo sed -i '/UvdEnabled=V1/ a HWUVD_H264Level51Support=V1' /etc/ati/amdpcsdb
sudo reboot
=Updating Catalyst/fglrx=
if amdcccle doesn't work and says Identifier is not a valid word. Use lower case letter in xorg.conf
or specify all the correct parameters. For example:
sudo dkms build -m fglrx -v '''9.012''' -k '''3.5.0-22'''-generic
sudo dkms install -m fglrx -v '''9.012''' -k '''3.5.0-22'''-generic
 
[[Category:Installation Documentation]]
Anonymous user

Navigation menu