Suspend2

From cchtml.com
Revision as of 03:58, 16 November 2005 by Skrionius (Talk)

Jump to: navigation, search

Suspend2 with fglrx 8.19

Suspend2 version 2.2-rc11 and the ati driver version 8.19.10 is the first combination which is supposed to work without any support tool like vbetool. Suspend2 is the next generation of software suspension tool that has more advanced configuration options and scripting possibilities which makes it more usable for hardwares that need workaround and work not with Suspend's original version.

Suspend1 is included in vanilla kernel, but Suspend2 is a patchset for specific kernel versions, and a package of hibernation script and scriplets (that do the suspend and resume process along with the kernel). You need to go to suspend2.net to download the patchset and patch the related kernel source, compile it and the fglrx kernel driver. Go there for more info about the suspend2 installing. If you want to use rc11 you will need kernel 2.6.14. Former versions of Suspend2 are not using well the new fglrx driver 8.19.10, so it is advisable to use suspend2 2.2-rc11. Older versions are said to be working with older versions of ati driver but it's likely you will need a working vbetool to use them.

The recent versions were tested by a bunch of users and reported to be fully usable. rage3d forum thread. It hibernates and resumes fglrx very well. You should have a perfectly restored X screen when you resume your machine. Hunt for bugs and flaws is still running and any discoveries should be described on this page.


Supsend2 experience

Bugs:

Samsung P35, using Ubuntu Breezy with kernel 2.6.14.2 and suspend2-2.2-rc11,fglrx 8.19.10 -- the screen isn't "redrawn"


Good working:

Abit NF7, Radeon 9600XT, 1G RAM, gentoo linux (kernel 2.6.14-suspend2-r1 with suspend 2.2-rc11), fglrx 8.19.10

AMD Athlon(tm) XP 2600+, nForce 2, 1Go RAM, Radeon 9200SE - FC4 suspend 2.2-rc11 using FC4 kernel from http://mhensler.de/swsusp/ and livna ATI RPM!