Difference between revisions of "Talk:Debian"

From cchtml.com
Jump to: navigation, search
(Problems with multiple cards and multiple monitors)
 
Line 1: Line 1:
 +
{{Talkpages}}
  
 
0. about wait & sleep modes on  catalyst-12.10 and kernel-3.2.0
 
0. about wait & sleep modes on  catalyst-12.10 and kernel-3.2.0
Line 33: Line 34:
  
 
The build instructions for 12.8 are what would have worked in earlier versions. But 12.8 unzips to amd-driver-installer-8.982-x86.x86_64.run so the build command should be reflecting this.
 
The build instructions for 12.8 are what would have worked in earlier versions. But 12.8 unzips to amd-driver-installer-8.982-x86.x86_64.run so the build command should be reflecting this.
 
== Problems with multiple cards and multiple monitors ==
 
 
When encountering problems under the following circumstances:
 
 
1. Multiple monitors on one card AND a monitor attached to VGA port.
 
2. More than one card.
 
 
...you may encounter problems that the resolution of the first monitor on the first card (usually identified as "CRT-1") may (a) not be recognized by manufacturer/model and instead the "Default Monitor" setting be used, and (b) therefore the resolution be set to a different resolution (e.g. 1600x1200) no matter what the xorg.conf file says.
 
 
If this happens, check if the log file '''/var/log/Xorg.0.log''' contains an entry like this one:
 
 
'''(II) fglrx(0): Cannot get EDID information for CRT1'''
 
 
...which may be followed later with:
 
 
'''(II) fglrx(0): Output CRT1 connected'''
 
 
'''(II) fglrx(0): Using user preference for initial modes'''
 
 
'''(II) fglrx(0): Output CRT1 using initial mode 1600x1200'''
 
 
The reason for this behavior seems to be either a timing problem during Xorg initialization (EDID info for CRT-1 not received quickly enough) or a problem with a dcc probe itself. A possible work-around is to not use the VGA connector (CRT-1) on the first card at all and use only the DVI and HDMI port (possibly with a HDMI-to-DVI adapter cable) and the problem disappears immediately (monitor gets recognized immediately and correct resolution is being used).
 
 
To avoid confusion with the Xorg configuration, you may want to delete '''/etc/X11/xorg.conf''' file and use the following command to have it generated (assuming 2 monitors per card):
 
 
'''  prompt$ aticonfig --initial --adapter=all --heads=2'''
 
 
This will create a complete and correct configuration file (you may want to change layout later) even if a VGA monitor is attached to the first card but that VGA monitor will not be recognized upon reboot.
 

Latest revision as of 19:40, 5 July 2013

TALK PAGES ARE NOT SUPPORT FORUMS

If you require help with installing the AMD fglrx driver, please consider a web forum or mailing list.

0. about wait & sleep modes on catalyst-12.10 and kernel-3.2.0

Previous words are wrong , right way is to do "modprobe radeonfb" after pure instalation amd-driver-installer-catalyst-12.10-x86.x86_64.run. It's blacklisted in

/etc/modprobe.d/fbdev-blacklist.conf. Comment string with it and make a new file f.e. wait.conf with "options radeonfb" in it. And WAIT and SLEEP mode become work correctly. By the way , fglrx-driver_12-6+point-1_i386.deb from testing breaks Wait&Sleep modes. And at last , preventing editing page makes bad only for you and others , not me .

The page is protected for 1 more week. It was protected against spam. You can wait 1 week or request a user and edit the page at any time. The wiki tells you why and how long a page is protected, so you don't have to make such comments in the future. -Mooninite (talk) 15:04, 6 February 2013 (UTC)

Did anyone _ever_ tried successfully to build a debian packet since about 2009??? I've used the --keep keyword of the installer and watched the code. This is ridiculous:

  1. Detect x* dir name corresponding to X_NAME
   case ${X_NAME} in
       woody|3.0) echo "Error: ${X_NAME} is no longer supported by this installer" ; exit 1 ;;
       etch|stable|4.0) X_DIR=x710; X_NAME=etch;;
       lenny|testing) X_DIR=x710; X_NAME=lenny;;
       sid|unstable) X_DIR=x710; X_NAME=sid;;
       experimental) X_DIR=x710; X_NAME=experimental;;
       *) echo "Error: invalid package name passed to --buildpkg" ; exit 1 ;;
   esac


Besides the fact that lenny hasn't been testing for a long time now, there isn't a X_DIR "x710" in this whole packet thus you don't need to wonder about it is failing all the time with the error: "cp: cannot stat `/tmp/fglrx-install.1GJKvS/x710_64a/*': No such file or directory"

[edit] xserver 1.12.3-1

This was rumored to address the segfaults. Does anyone have experience with this version?

Jasmine Hassan: xserver-xorg-core 1.12.3.902-1 with fglrx-driver 12-6+point-1 works for me. Using Radeon HD 7670M, on Inspiron 15R 5520.

[edit] 12.8 / 8.982

The build instructions for 12.8 are what would have worked in earlier versions. But 12.8 unzips to amd-driver-installer-8.982-x86.x86_64.run so the build command should be reflecting this.