Difference between revisions of "Talk:Ubuntu Feisty Installation Guide"

From cchtml.com
Jump to: navigation, search
(Problem with login screen?)
(Problem with login screen?)
Line 74: Line 74:
 
http://ubuntuforums.org/showthread.php?t=301941
 
http://ubuntuforums.org/showthread.php?t=301941
  
== Problem with login screen? ==
+
== Problem with xorg.conf settings? ==
  
 
As i was trying to work through this, I noticed that every time i would add those options to the xorg.conf file, KDE would no longer start unless I manually started it (startx), but then it would seem that no graphics drivers would load, and I'd have to restart loading fglrx. After several times of going through this process, trying to find out what went wrong, I decided NOT to add the 'Option "AIGLX" "off"' to the xorg.conf file. Then it booted perfectly, and everything was working like it should.
 
As i was trying to work through this, I noticed that every time i would add those options to the xorg.conf file, KDE would no longer start unless I manually started it (startx), but then it would seem that no graphics drivers would load, and I'd have to restart loading fglrx. After several times of going through this process, trying to find out what went wrong, I decided NOT to add the 'Option "AIGLX" "off"' to the xorg.conf file. Then it booted perfectly, and everything was working like it should.
  
 
In case you need to know, I am using Kbuntu with a Radeon 9800 Pro
 
In case you need to know, I am using Kbuntu with a Radeon 9800 Pro

Revision as of 18:14, 11 June 2007

Not works with Feisty Fawn Herd 5

The patch not works at this: sudo patch < ~/fglrx-2.6.20.patch the system asks for file can't found it.
UPDATE: The patch seems works fine but still not working for 3D acceleration install..

  • OpenGL vendor string: Mesa project: www.mesa3d.org
  • OpenGL renderer string: Mesa GLX Indirect
  • OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

Contents

This is all hard

Very hard work indeed and it still doesn't do dual head. is there any way of getting a non 3d driver going, which will just show a movie on my projector. I rebooted a lot today, a lot.

OpenGL not working, so no Google Earth - and many other programs

I did my share of rebooting, too.
I'm really frustrated.
Is this a hardware limitation (I have X1650 Pro) or a driver limitation?

You need to troubleshoot your installation method. -- Mooninite 14:10, 27 March 2007 (CDT)

2.6.20 Patching

IMPORTANT: This method will not work with 2.6.20.* kernels. Is this still true? My feisty install is kernel 2.6.20-13-generic and it was trivial to install fglrx using the first method mentioned. If the second method is still really required, it would be good to say why (eg, something is busted in Ubuntu's 26.20 ?)

aticonfig --overlay-type=Xv: core dumps

      • glibc detected *** aticonfig: munmap_chunk(): invalid pointer: 0xbfe04a91 ***
= Backtrace: ===

/lib/tls/i686/cmov/libc.so.6(cfree+0x1bb)[0xb7d65f5b] aticonfig[0x805be17] aticonfig[0x805bf2a] aticonfig[0x8052f5a] aticonfig[0x80531aa] aticonfig[0x804ab0d] aticonfig[0x80497d9] aticonfig[0x80496cb] /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xdc)[0xb7d10ebc] aticonfig[0x8049601]

Doesn't crash with the --initial option.

Rebooted and this time it just hangs. (2.6.20-13 generic; Mobility Radeon 9700.)

aticonfig Core Dumps

I found the problem with these instructions for those of us getting the initial core dumps when using aticonfig --initial or --overlay

The problem is the order in which the instructions are given.

To fix this I had to first black list the fglrx and then reboot.

If you don't black list this driver and reboot first, you will get an error when you run


sudo dpkg -i xorg-driver-fglrx_8.36.5-1*.deb


The error you will get is the following:


Starting atieventsd: already started



This will cause all aticonfig settings to choke.

Dual screen

I finally managed to get fglrx working with two screens with an ATI radeon X1300. Xinerama resulted in buggy mouse pointer on second screen. All in one big desktop seems to work without any problems. I followed this guide: http://ubuntuforums.org/showthread.php?t=301941

Problem with xorg.conf settings?

As i was trying to work through this, I noticed that every time i would add those options to the xorg.conf file, KDE would no longer start unless I manually started it (startx), but then it would seem that no graphics drivers would load, and I'd have to restart loading fglrx. After several times of going through this process, trying to find out what went wrong, I decided NOT to add the 'Option "AIGLX" "off"' to the xorg.conf file. Then it booted perfectly, and everything was working like it should.

In case you need to know, I am using Kbuntu with a Radeon 9800 Pro