Difference between revisions of "Talk:Ubuntu Feisty Installation Guide"

From cchtml.com
Jump to: navigation, search
(AMD Watermark with 8.39.4 Drivers)
 
(25 intermediate revisions by 15 users not shown)
Line 1: Line 1:
Not works with Feisty Fawn Herd 5
+
I'm out of lgeaue here. Too much brain power on display!
:: The patch not works at this: '''sudo patch < ~/fglrx-2.6.20.patch''' the system asks for file can't found it.
+
::: UPDATE: The patch seems works fine but still not working for 3D acceleration install..
+
  
----
 
  
*OpenGL vendor string: Mesa project: www.mesa3d.org
 
*OpenGL renderer string: Mesa GLX Indirect
 
*OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
 
  
== This is all hard ==
 
  
Very hard work indeed and it still doesn't do dual head. is there any way of getting a non 3d driver going, which will just show a movie on my projector. I rebooted a lot today, a lot.
+
Is this still up to date? In particular the "Disable Composite Extension" part? I mean, does the disabling still need to be done? --[[Special:Contributions/88.73.201.32|88.73.201.32]] 05:26, 18 June 2011 (CDT)
 
+
== OpenGL not working, so no Google Earth - and many other programs ==
+
 
+
I did my share of rebooting, too.<br>
+
I'm really frustrated.<br>
+
Is this a hardware limitation (I have X1650 Pro) or a driver limitation?
+
:You need to troubleshoot your installation method. -- [[User:Mooninite|Mooninite]] 14:10, 27 March 2007 (CDT)
+
 
+
== 2.6.20 Patching ==
+
 
+
''IMPORTANT: This method will not work with 2.6.20.* kernels.'' Is this still true? My feisty install is kernel 2.6.20-13-generic and it was trivial to install fglrx using the first method mentioned.  If the second method is still really required, it would be good to say why (eg, something is busted in Ubuntu's 26.20 ?)
+
 
+
== aticonfig --overlay-type=Xv: core dumps ==
+
 
+
*** glibc detected *** aticonfig: munmap_chunk(): invalid pointer: 0xbfe04a91 ***
+
======= Backtrace: =========
+
/lib/tls/i686/cmov/libc.so.6(cfree+0x1bb)[0xb7d65f5b]
+
aticonfig[0x805be17]
+
aticonfig[0x805bf2a]
+
aticonfig[0x8052f5a]
+
aticonfig[0x80531aa]
+
aticonfig[0x804ab0d]
+
aticonfig[0x80497d9]
+
aticonfig[0x80496cb]
+
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xdc)[0xb7d10ebc]
+
aticonfig[0x8049601]
+
 
+
Doesn't crash with the --initial option.
+
 
+
Rebooted and this time it just hangs.  (2.6.20-13 generic; Mobility Radeon 9700.)
+
 
+
== aticonfig Core Dumps ==
+
 
+
I found the problem with these instructions for those of us getting the initial core dumps when using aticonfig --initial or --overlay
+
 
+
The problem is the order in which the instructions are given. 
+
 
+
To fix this I had to first black list the fglrx and then reboot.
+
 
+
If you don't black list this driver and reboot first, you will get an error when you run
+
 
+
----
+
 
+
sudo dpkg -i xorg-driver-fglrx_8.36.5-1*.deb
+
 
+
----
+
 
+
The error you will get is the following:
+
 
+
----
+
Starting atieventsd: already started
+
 
+
----
+
 
+
 
+
This will cause all aticonfig settings to choke.
+
 
+
== Dual screen ==
+
 
+
I finally managed to get fglrx working with two screens with an ATI radeon X1300. Xinerama resulted in buggy mouse pointer on second screen. All in one big desktop seems to work without any problems. I followed this guide:
+
http://ubuntuforums.org/showthread.php?t=301941
+
 
+
== Problem with xorg.conf settings? ==
+
 
+
As i was trying to work through this, I noticed that every time I added those options to the xorg.conf file, KDE would no longer start unless I manually started it (startx), but then it would seem that no graphics drivers would load, and I'd have to restart installing/setting up fglrx. After several rounds of going through this process, I  just decided NOT to add the 'Option "AIGLX" "off"' to the xorg.conf file. Then it booted perfectly, and everything was working like it should.
+
 
+
In case you need to know, I am using Kbuntu with a Radeon 9800 Pro
+
 
+
== Script ==
+
 
+
In case anyone's interested, I wrote up a script that installs the driver. It's [http://sheeettin.ath.cx/scripts/fglrx.txt here], only for Feisty. (I tried making it release-independent, but it was too hard.) My computer gets shut down at night (it's not so much a server as a computer for personal use), so try again later if you get a 503. (Also, could my script be mentioned in the article somehow? I didn't see a good place to put it.) &mdash;&nbsp;[[User:SheeEttin|SheeEttin]]&nbsp;{[[User_talk:SheeEttin|T]]/[[Special:Contributions/SheeEttin|C]]} 17:54, 13 July 2007 (CDT)
+
 
+
== AMD Watermark with 8.39.4 Drivers ==
+
 
+
Just installed the new 8.39.4 drivers as per the guide, and now there is a square overlayed on the lower right corner of the screen that says "AMD Testing use only". It's very annoying, and I'm wondering if anyone else is getting this, or knows how to remove it? I almost wonder if Ati put up a development version on their download page by mistake...
+
This is on Kubuntu 7.04 with a Radeon 9600xt -- [[User:71.34.23.10|71.34.23.10]]
+
 
+
edit: just saw this at [http://www.phoronix.com/?page=news_item&px=NTkwNg www.phoronix.com]. seems to be an issue with a signiture file that isn't getting generated with the --buildpkg argument. Guess the only solution is to downgrade until Ati fixes it. -- [[User:71.34.23.10|71.34.23.10]]
+
 
+
:Yup. If you must have the drivers ''now'', you can apparently use the GUI installer and it'll work. &mdash;&nbsp;[[User:SheeEttin|SheeEttin]]&nbsp;{[[User_talk:SheeEttin|T]]/[[Special:Contributions/SheeEttin|C]]} 12:30, 20 July 2007 (CDT)
+
 
+
::ATI is no longer offering the 8.39.4 drivers. Download page is back to 8.38.6. If you managed to grab the file while it was available, there is a workaround posted in [http://www.rage3d.com/board/showthread.php?p=1335043887 this thread].
+

Latest revision as of 04:28, 18 June 2011

I'm out of lgeaue here. Too much brain power on display!



Is this still up to date? In particular the "Disable Composite Extension" part? I mean, does the disabling still need to be done? --88.73.201.32 05:26, 18 June 2011 (CDT)