Difference between revisions of "Talk:Ubuntu Gutsy Installation Guide"

From cchtml.com
Jump to: navigation, search
(Need update the topic to Catalyst 7.11)
(Undo revision 6799 by 203.172.208.43 (talk))
 
(40 intermediate revisions by 19 users not shown)
Line 1: Line 1:
== Need update the topic to Catalyst 7.11 ==
+
{{Talkpages}}
Can anyone update the installation method 2 to AMD Catalyst 7.11?
+
The procedure is the same or not? Has hanyone tested it?
+
  
 +
I was unable to execute "sudo sh ati-driver-installer-8-02-x86.x86_64.run --buildpkg Ubuntu/gutsy" because it says missing lib32.  i had to install lib32 package which should have been mentioned in the documentation
  
-> I just tested the procedure. It is the (nearly) same ...
+
== dkms? ==
Found some issues till it worked for me.
+
  
  sudo gedit /etc/init.d/ati-module-fix
+
I don't see any instructions for this newfangled dkms thing... Is it it done automatically? — [[User:SheeEttin|SheeEttin]] {[[User_talk:SheeEttin|T]]/[[Special:Contributions/SheeEttin|C]]} 09:13, 24 December 2007 (CST)
  
In ati-module-fix I replaced
+
ANSWER: just install it before installing fglrx packages... they will invoke it. Nothing to do.
  
  ln -sf /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/
 
with
 
  ln -sf /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/fglrx.ko
 
  
after savig the file
+
== APT/Aptitude ==
  sudo chmod +x /etc/init.d/ati-module-fix
+
This guide use apt-get. Sometimes the apt-get and aptitude are interchangeable, but not always. Please don't edit this guide without knowing how use aptitude. For instance the commend "aptitude install -f" is not secure, can provoke damages (especially for "unstable" distributions).
 +
In my opinion apt-get is better for this guide. --[[User:Subvertigo|Subvertigo]] 15:26, 13 January 2008 (CST)
  
In my installation gdm starts with sequence 13. So I did
+
== Problems with 3D acceleration ==
 +
When I try to load an app. that lacks 3D acceleration like Celestia, Stellarium etc. my computer just logs off, and I have to log back in!? Please guide me.
  
  sudo update-rc.d ati-module-fix defaults 12
 
  
 +
==Found issues==
  
"If you check the box to enable the restricted driver and reboot, it should work."
+
===Mipmapping in Compiz===
 +
When mipmapping is enabled in compiz modules then they the contents don't show up. Disabling mipmapping fixes these problems. Ubunty 7.10 and ATI 8.1.
  
If I check the the box in "resricted manager" the line
+
===Kibadock glitches===
  DISABLED_MODULES="fglrx"
+
Kibadock has a black background when acceleration is NOT enabled. When acceleration IS enabled it has some problems with some applications where windows aren't visible.
in etc/default/linux-restricted-modules-common is changed back to
+
  DISABLED_MODULES=""
+
I leaved it unchecked now.
+
  
 +
===Flickering video===
 +
When videos are played in various players including embedded on websites with firefox then the video flickers with black.
  
So my "restricted manager" reports for the ATI driver
+
    * Has anyone found a solution to the flickering?  I find it also occurs in 3d-enabled games. 11:56, 7 March 2008 (CST)
activated: no    in use: yes
+
  
 +
It seems to be tied to compiz. When I disable desktop effects (System --> Preferences --> Appearance --> Visual Effects --> Set to "None") the flickering on videos goes away. If I enable any degree of effects, even the lowest setting, the flickering reappears again. Very annoying. I'm running driver version 8.44.3 (don't recall the Catalyst version associated with this) on an X1950XT.
  
EDIT (subvertigo): doesn't work for me... see below "still mesa"... X1400
+
Update: Updated to driver version 8.47.3 and the same flickering on video continues as long as desktop effects are enabled.
  
== Updated some information only applicable for Gutsy ==
+
==Comments==
I've updated some minor details about the fglrx-installation in Gutsy:
+
* By default, Gutsy (and Feisty too) now have Universe and Multiverse enabled
+
* The fglrx-version in Gutsy's linux-restricted-modules is 8.37.6 and not 8.28.8
+
[[User:Jealma|Jealma]] 04:35, 19 October 2007 (CDT)
+
  
== libGL error ==
+
===Infinite Loop===
* fglrxinfo gives:  libGL.so.1: cannot open shared object file.
+
Looks to me like 128.8.120.187, which seems to be a computer name Prospector in a lab of the University of Maryland Institute for Advanced Computer Studies, found my solution at http://ubuntuforums.org/showthread.php?t=663111&p=4109726, and put in a comment on the infinite loop possibility on 23:28, 21 February 2008, under the 4.1 3D desktop effects section. I couldn't find a fix for that anywhere, but finally figured it out myself, and let others know of the solution. It's just cool to see that someone thought my contribution was good enough for the Unofficial ATI Linux Driver Wiki's Ubuntu Gutsy Installation Guide, which I keep coming to over and over as I mess up my system again and again :D
* Fixed with command:
+
sudo ln /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1
+
  
== installation hint ==
+
So, whenever you get a solution to anything, put it online. It might be important.
  
I followed this guide and fglrxinfo yielded the desired output.
+
~ pgn674
 
+
But then I still got the following problems:
+
* crash/restart of X when trying to run glxgears
+
* crash/restart of X when trying to watch mythtv recording
+
* visual artefacts from window creation
+
 
+
The cause I assumed in that:
+
 
+
<code>glxinfo | grep direct</code>
+
 
+
did not yield 'yes' but 'no' and 'Mesa Indirect'
+
 
+
Long search, quick solution:
+
 
+
<code>sudo apt-get remove xserver-xgl</code>
+
 
+
'''Note:''' I don't really know what this actually does in the context of a desired installation, so try at your own risk. I assume this being installed from my earlier Feisty installation where I tried out compiz and AIGLX was not supported by the driver.
+
 
+
After removing the xserver-xgl package, all problems described above vanished.
+
 
+
Maybe someone with more detailed knowledge might find it useful to add a paragraph to the page.
+
 
+
Comment: I had a lot of trouble until I found your solution. Removing xserver-xgl made most of the graphical artifacts disappear (I still have some black bars in the bottom right corner of one screen), and made my dual screen setup work again. Should this be in the general guide?
+
 
+
Comment: I was seeing some very similar behavior after following this tutorial. glxgears would cause gdm to crash and the artifacts were left on the screen. The system would also be dog slow, moving windows was very laggy. Removing xserver-xgl did the trick for me!
+
 
+
== still Mesa ==
+
 
+
Hi,
+
 
+
I never had problems until Gutsy & 7.11 came:
+
(bmhm@Sentinux)[~] $ cat /var/log/Xorg.0.log | grep "(WW)"
+
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
+
(WW) Including the default font path  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/cyrillic,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType.
+
(WW) fglrx(0): board is an unknown third party board, chipset is supported
+
(WW) fglrx(0): ***********************************************
+
(WW) fglrx(0): * DRI initialization failed!                  *
+
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
+
(WW) fglrx(0): * 2D acceleraton available (MMIO)            *
+
(WW) fglrx(0): * no 3D acceleration available                *
+
(WW) fglrx(0): ********************************************* *
+
 
+
and
+
 
+
(bmhm@Sentinux)[~] $  cat /var/log/Xorg.0.log | grep "(EE)"
+
(EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1000)
+
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
+
(EE) AIGLX: Screen 0 is not DRI capable
+
 
+
Any Ideas? It did work before (on feisty, using older drivers)!! Help!! --[[User:212.62.64.34|212.62.64.34]] 14:08, 22 November 2007 (CST)
+
 
+
NEW (by subvertigo):
+
I have the same identical problem (identical logs). Before with Feisty+8.43.2 or Gutsy+8.43.2 i had no problems... :-(
+
My pc is a Dell Inspiron 6400 with ATI X1400.
+
fglrinfo reports using Mesa drivers.
+
 
+
I tried to add or remove "fglrx" from /etc/default/linux-restricted-modules-common and it has no effects. The "restricted manager" signals that ati driver is not in use when fglrx is blacklisted. I don't understand if it have to be blacklisted or not.
+

Latest revision as of 14:36, 2 June 2011

TALK PAGES ARE NOT SUPPORT FORUMS

If you require help with installing the AMD fglrx driver, please consider a web forum or mailing list.

I was unable to execute "sudo sh ati-driver-installer-8-02-x86.x86_64.run --buildpkg Ubuntu/gutsy" because it says missing lib32. i had to install lib32 package which should have been mentioned in the documentation

Contents

[edit] dkms?

I don't see any instructions for this newfangled dkms thing... Is it it done automatically? — SheeEttin {T/C} 09:13, 24 December 2007 (CST)

ANSWER: just install it before installing fglrx packages... they will invoke it. Nothing to do.


[edit] APT/Aptitude

This guide use apt-get. Sometimes the apt-get and aptitude are interchangeable, but not always. Please don't edit this guide without knowing how use aptitude. For instance the commend "aptitude install -f" is not secure, can provoke damages (especially for "unstable" distributions). In my opinion apt-get is better for this guide. --Subvertigo 15:26, 13 January 2008 (CST)

[edit] Problems with 3D acceleration

When I try to load an app. that lacks 3D acceleration like Celestia, Stellarium etc. my computer just logs off, and I have to log back in!? Please guide me.


[edit] Found issues

[edit] Mipmapping in Compiz

When mipmapping is enabled in compiz modules then they the contents don't show up. Disabling mipmapping fixes these problems. Ubunty 7.10 and ATI 8.1.

[edit] Kibadock glitches

Kibadock has a black background when acceleration is NOT enabled. When acceleration IS enabled it has some problems with some applications where windows aren't visible.

[edit] Flickering video

When videos are played in various players including embedded on websites with firefox then the video flickers with black.

   * Has anyone found a solution to the flickering?  I find it also occurs in 3d-enabled games. 11:56, 7 March 2008 (CST)

It seems to be tied to compiz. When I disable desktop effects (System --> Preferences --> Appearance --> Visual Effects --> Set to "None") the flickering on videos goes away. If I enable any degree of effects, even the lowest setting, the flickering reappears again. Very annoying. I'm running driver version 8.44.3 (don't recall the Catalyst version associated with this) on an X1950XT.

Update: Updated to driver version 8.47.3 and the same flickering on video continues as long as desktop effects are enabled.

[edit] Comments

[edit] Infinite Loop

Looks to me like 128.8.120.187, which seems to be a computer name Prospector in a lab of the University of Maryland Institute for Advanced Computer Studies, found my solution at http://ubuntuforums.org/showthread.php?t=663111&p=4109726, and put in a comment on the infinite loop possibility on 23:28, 21 February 2008, under the 4.1 3D desktop effects section. I couldn't find a fix for that anywhere, but finally figured it out myself, and let others know of the solution. It's just cool to see that someone thought my contribution was good enough for the Unofficial ATI Linux Driver Wiki's Ubuntu Gutsy Installation Guide, which I keep coming to over and over as I mess up my system again and again :D

So, whenever you get a solution to anything, put it online. It might be important.

~ pgn674