Difference between revisions of "Talk:Ubuntu Gutsy Installation Guide"

From cchtml.com
Jump to: navigation, search
(cleaned)
(Undo revision 6799 by 203.172.208.43 (talk))
 
(24 intermediate revisions by 16 users not shown)
Line 1: Line 1:
== Method 2 for Catalysy 7.11 ==
+
{{Talkpages}}
Done.
+
  
== Suspend/Hibernation with Catalyst 7.11 & Gutsy ==
+
I was unable to execute "sudo sh ati-driver-installer-8-02-x86.x86_64.run --buildpkg Ubuntu/gutsy" because it says missing lib32. i had to install lib32 package which should have been mentioned in the documentation
I hoped that with these drivers and Gutsty, the suspend problem would have been solved. Unfortunately it isn't for me.
+
I tried also to apply the patches to "acpi-support" (like doing with Feisty) but unsuccessfully.
+
Any working experiences? Solutions? Workarounds?
+
  
== installation hint ==
+
== dkms? ==
  
I followed this guide and fglrxinfo yielded the desired output.
+
I don't see any instructions for this newfangled dkms thing... Is it it done automatically? — [[User:SheeEttin|SheeEttin]] {[[User_talk:SheeEttin|T]]/[[Special:Contributions/SheeEttin|C]]} 09:13, 24 December 2007 (CST)
  
But then I still got the following problems:
+
ANSWER: just install it before installing fglrx packages... they will invoke it. Nothing to do.
* crash/restart of X when trying to run glxgears
+
* crash/restart of X when trying to watch mythtv recording
+
* visual artefacts from window creation
+
  
The cause I assumed in that:
 
  
<code>glxinfo | grep direct</code>
+
== APT/Aptitude ==
 +
This guide use apt-get. Sometimes the apt-get and aptitude are interchangeable, but not always. Please don't edit this guide without knowing how use aptitude. For instance the commend "aptitude install -f" is not secure, can provoke damages (especially for "unstable" distributions).
 +
In my opinion apt-get is better for this guide. --[[User:Subvertigo|Subvertigo]] 15:26, 13 January 2008 (CST)
  
did not yield 'yes' but 'no' and 'Mesa Indirect'
+
== Problems with 3D acceleration ==
 +
When I try to load an app. that lacks 3D acceleration like Celestia, Stellarium etc. my computer just logs off, and I have to log back in!? Please guide me.
  
Long search, quick solution:
 
  
<code>sudo apt-get remove xserver-xgl</code>
+
==Found issues==
  
'''Note:''' I don't really know what this actually does in the context of a desired installation, so try at your own risk. I assume this being installed from my earlier Feisty installation where I tried out compiz and AIGLX was not supported by the driver.
+
===Mipmapping in Compiz===
 +
When mipmapping is enabled in compiz modules then they the contents don't show up. Disabling mipmapping fixes these problems. Ubunty 7.10 and ATI 8.1.
  
After removing the xserver-xgl package, all problems described above vanished.
+
===Kibadock glitches===
 +
Kibadock has a black background when acceleration is NOT enabled. When acceleration IS enabled it has some problems with some applications where windows aren't visible.
  
Maybe someone with more detailed knowledge might find it useful to add a paragraph to the page.
+
===Flickering video===
 +
When videos are played in various players including embedded on websites with firefox then the video flickers with black.
  
Comment: I had a lot of trouble until I found your solution. Removing xserver-xgl made most of the graphical artifacts disappear (I still have some black bars in the bottom right corner of one screen), and made my dual screen setup work again. Should this be in the general guide?
+
    * Has anyone found a solution to the flickering?  I find it also occurs in 3d-enabled games. 11:56, 7 March 2008 (CST)
  
Comment: I was seeing some very similar behavior after following this tutorial. glxgears would cause gdm to crash and the artifacts were left on the screen. The system would also be dog slow, moving windows was very laggy. Removing xserver-xgl did the trick for me!
+
It seems to be tied to compiz. When I disable desktop effects (System --> Preferences --> Appearance --> Visual Effects --> Set to "None") the flickering on videos goes away. If I enable any degree of effects, even the lowest setting, the flickering reappears again. Very annoying. I'm running driver version 8.44.3 (don't recall the Catalyst version associated with this) on an X1950XT.
  
== still Mesa ==
+
Update: Updated to driver version 8.47.3 and the same flickering on video continues as long as desktop effects are enabled.
  
Hi,
+
==Comments==
  
I never had problems until Gutsy & 7.11 came:
+
===Infinite Loop===
(bmhm@Sentinux)[~] $ cat /var/log/Xorg.0.log | grep "(WW)"
+
Looks to me like 128.8.120.187, which seems to be a computer name Prospector in a lab of the University of Maryland Institute for Advanced Computer Studies, found my solution at http://ubuntuforums.org/showthread.php?t=663111&p=4109726, and put in a comment on the infinite loop possibility on 23:28, 21 February 2008, under the 4.1 3D desktop effects section. I couldn't find a fix for that anywhere, but finally figured it out myself, and let others know of the solution. It's just cool to see that someone thought my contribution was good enough for the Unofficial ATI Linux Driver Wiki's Ubuntu Gutsy Installation Guide, which I keep coming to over and over as I mess up my system again and again :D
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
+
(WW) Including the default font path  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/cyrillic,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType.
+
(WW) fglrx(0): board is an unknown third party board, chipset is supported
+
(WW) fglrx(0): ***********************************************
+
(WW) fglrx(0): * DRI initialization failed!                  *
+
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
+
(WW) fglrx(0): * 2D acceleraton available (MMIO)            *
+
(WW) fglrx(0): * no 3D acceleration available                *
+
(WW) fglrx(0): ********************************************* *
+
  
and
+
So, whenever you get a solution to anything, put it online. It might be important.
  
(bmhm@Sentinux)[~] $  cat /var/log/Xorg.0.log | grep "(EE)"
+
~ pgn674
(EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1000)
+
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
+
(EE) AIGLX: Screen 0 is not DRI capable
+
 
+
Any Ideas? It did work before (on feisty, using older drivers)!! Help!! --[[User:212.62.64.34|212.62.64.34]] 14:08, 22 November 2007 (CST)
+
 
+
I SOLVED (subvertigo):
+
The problem was the fglrx.ko . The symbolic link have been overwritten at each reboot.
+
Check if the fglrx.ko in the "volatile" folder is a symbolic link or not to that in the "misc" folder (Gnome reports an arrow on the icon if it is, and must have the same dimension). If it is the same problem see the first paragraph to see how I solved.
+
 
+
The symbolic link is gone after a reboot. Filesize of the one in the misc folder is 2084611 bytes and the one in the volatile folder is 1058754 bytes. I don't know where/what this copying is done. :(
+
 
+
Performing the following command:
+
 
+
find / -name 'fglrx*.ko'
+
 
+
Results in:
+
 
+
/lib/modules/2.6.22-14-generic/volatile/fglrx.ko
+
/lib/modules/2.6.22-14-generic/misc/fglrx.ko
+
 
+
So where this 1058754 bytes sized version exists on the system is unclear to me.
+
 
+
== (Partially) Installed but 7.11 Driver NOT used ==
+
 
+
The catalyst control center is available under "accessories" and list the following.
+
 
+
Software:
+
* Driver version : 8.43.2
+
* Catalyst Control Center Version : 1.6
+
 
+
OpenGL:
+
* .. Provider : Mesa project ...
+
* .. Renderer : Mesa GLX Indirect
+
* .. Version : 1.4 (2.1 Mesa 7.0.1)
+
 
+
Checklist:
+
* "Restricted" repositories not commented
+
* The "restricter driver manager" says that the driver is enabled and in use.
+
* Symbolic link exists
+
 
+
Really don't know what the problem is.
+
 
+
EDIT (subvertigo) The problem is almost surely the "fglrx.ko"... see the first paragraph for the solution.
+
Moreover the "restricted manager" should say that the driver is NOT enabled (equivalent to blacklist the original "fglrx" in linux-restricted-modules-common).
+
 
+
== Method 1 fails, since xorg-driver-fglrx and fglrx kernel module versions differ ==
+
xorg-driver-fglrx is version is 8.38.7-1 and the fglrx kernel module version in linux-restricted-modules-generic is still 8.37.6.
+
 
+
Xorg complains:
+
ad@homer:~$ cat /var/log/Xorg.0.log | grep "(EE)"
+
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
+
(EE) AIGLX: Screen 0 is not DRI capable
+

Latest revision as of 14:36, 2 June 2011

TALK PAGES ARE NOT SUPPORT FORUMS

If you require help with installing the AMD fglrx driver, please consider a web forum or mailing list.

I was unable to execute "sudo sh ati-driver-installer-8-02-x86.x86_64.run --buildpkg Ubuntu/gutsy" because it says missing lib32. i had to install lib32 package which should have been mentioned in the documentation

Contents

[edit] dkms?

I don't see any instructions for this newfangled dkms thing... Is it it done automatically? — SheeEttin {T/C} 09:13, 24 December 2007 (CST)

ANSWER: just install it before installing fglrx packages... they will invoke it. Nothing to do.


[edit] APT/Aptitude

This guide use apt-get. Sometimes the apt-get and aptitude are interchangeable, but not always. Please don't edit this guide without knowing how use aptitude. For instance the commend "aptitude install -f" is not secure, can provoke damages (especially for "unstable" distributions). In my opinion apt-get is better for this guide. --Subvertigo 15:26, 13 January 2008 (CST)

[edit] Problems with 3D acceleration

When I try to load an app. that lacks 3D acceleration like Celestia, Stellarium etc. my computer just logs off, and I have to log back in!? Please guide me.


[edit] Found issues

[edit] Mipmapping in Compiz

When mipmapping is enabled in compiz modules then they the contents don't show up. Disabling mipmapping fixes these problems. Ubunty 7.10 and ATI 8.1.

[edit] Kibadock glitches

Kibadock has a black background when acceleration is NOT enabled. When acceleration IS enabled it has some problems with some applications where windows aren't visible.

[edit] Flickering video

When videos are played in various players including embedded on websites with firefox then the video flickers with black.

   * Has anyone found a solution to the flickering?  I find it also occurs in 3d-enabled games. 11:56, 7 March 2008 (CST)

It seems to be tied to compiz. When I disable desktop effects (System --> Preferences --> Appearance --> Visual Effects --> Set to "None") the flickering on videos goes away. If I enable any degree of effects, even the lowest setting, the flickering reappears again. Very annoying. I'm running driver version 8.44.3 (don't recall the Catalyst version associated with this) on an X1950XT.

Update: Updated to driver version 8.47.3 and the same flickering on video continues as long as desktop effects are enabled.

[edit] Comments

[edit] Infinite Loop

Looks to me like 128.8.120.187, which seems to be a computer name Prospector in a lab of the University of Maryland Institute for Advanced Computer Studies, found my solution at http://ubuntuforums.org/showthread.php?t=663111&p=4109726, and put in a comment on the infinite loop possibility on 23:28, 21 February 2008, under the 4.1 3D desktop effects section. I couldn't find a fix for that anywhere, but finally figured it out myself, and let others know of the solution. It's just cool to see that someone thought my contribution was good enough for the Unofficial ATI Linux Driver Wiki's Ubuntu Gutsy Installation Guide, which I keep coming to over and over as I mess up my system again and again :D

So, whenever you get a solution to anything, put it online. It might be important.

~ pgn674