Difference between revisions of "Troubleshooting"

From cchtml.com
Jump to: navigation, search
(Undo revision 7118 by 80.171.131.94 (talk))
(_ZN17SegmentMapManager13deleteMappingEP9CMMClient+0x3f/0x170)
Line 169: Line 169:
 
What also works, is to enable tear free desktop in config in 11.2+.
 
What also works, is to enable tear free desktop in config in 11.2+.
  
=== _ZN17SegmentMapManager13deleteMappingEP9CMMClient+0x3f/0x170 ===
+
What an awesome way to explain this-now I know eevyhrting!
 
+
<b>UPDATE</b>: The problem I have reported here is no more reproducible with the fglrx revision 11.03 (ati-driver-installer-11-3-x86.x86_64.run) within two months of testing. Many thanks to the guys that fixed this !
+
 
+
Strange name for a bug but this is what your kernel might say if your screen freeze completely while using two sessions and switching between them. The bug is more likely to occur while doing the session switch, but can also occur in a later moment. I have observed it while starting a new application, or while doing a simple page scrolling. Anyway, in case of this bug the graphic is completely unusable as well as the console switching, but the OS and non graphic application continue to work. A reboot it the only way I know to bring back the screen to normal operations. Then your /var/log/kernel.log might contain something like this:
+
<pre>
+
 
+
Dec 16 07:22:13 cube kernel: [1178220.704151] BUG: unable to handle kernel NULL pointer dereference at 00000000000001c0
+
Dec 16 07:22:13 cube kernel: [1178220.704168] IP: [<ffffffffa030ef0f>] _ZN17SegmentMapManager13deleteMappingEP9CMMClient+0x3f/0x170 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704319] PGD 171a1b067 PUD 1b5376067 PMD 0
+
Dec 16 07:22:13 cube kernel: [1178220.704330] Oops: 0000 [#1] SMP
+
Dec 16 07:22:13 cube kernel: [1178220.704337] last sysfs file: /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
+
Dec 16 07:22:13 cube kernel: [1178220.704346] CPU 1
+
Dec 16 07:22:13 cube kernel: [1178220.704351] Modules linked in: cramfs ext2 iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 iptable_filter ip_tables x_tables fglrx(P) ftdi_sio usbserial ext3 jbd mbcache btrfs nls_utf8 zlib_deflate nls_cp437 crc32c vfat
+
fat libcrc32c radeon ttm drm_kms_helper drm i2c_algo_bit ppdev lp sco bridge stp bnep rfcomm l2cap crc16 powernow_k8 cpufreq_stats cpufreq_powersave cpufreq_conservative cpufreq_userspace binfmt_misc fuse loop snd_hda_codec_atihdmi snd_hda_codec_realtek snd_usb_audio snd
+
_hda_intel snd_hda_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_usb_lib snd_hwdep snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device sd_mod btusb crc_t10dif usblp asus_atk0110 bluetooth snd parport_pc i2c_piix4 parport psmouse rfkill button k8tem
+
p i2c_core shpchp serio_raw processor pcspkr evdev soundcore pci_hotplug edac_core snd_page_alloc edac_mce_amd usbhid hid nfs lockd fscache nfs_acl auth_rpcgss sunrpc usb_storage ata_generic ahci firewire_ohci fi
+
Dec 16 07:22:13 cube kernel: rewire_core crc_itu_t sky2 thermal thermal_sys pata_atiixp libata ohci_hcd ehci_hcd scsi_mod usbcore nls_base [last unloaded: fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516] Pid: 7344, comm: Xorg Tainted: P        W  2.6.32-5-amd64 #1 System Product Name
+
Dec 16 07:22:13 cube kernel: [1178220.704516] RIP: 0010:[<ffffffffa030ef0f>]  [<ffffffffa030ef0f>] _ZN17SegmentMapManager13deleteMappingEP9CMMClient+0x3f/0x170 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516] RSP: 0018:ffff88003e91bc38  EFLAGS: 00010292
+
Dec 16 07:22:13 cube kernel: [1178220.704516] RAX: 0000000000000000 RBX: ffffc9001236f620 RCX: 00000000000006b0
+
Dec 16 07:22:13 cube kernel: [1178220.704516] RDX: 0000000000000000 RSI: ffffc90012398e00 RDI: 0000000000000140
+
Dec 16 07:22:13 cube kernel: [1178220.704516] RBP: ffffc90012398e00 R08: ffff88020b560008 R09: ffffc9001237b620
+
Dec 16 07:22:13 cube kernel: [1178220.704516] R10: 00000000000006bc R11: 0000000000000001 R12: ffff88003e91bc58
+
Dec 16 07:22:13 cube kernel: [1178220.704516] R13: 00000000000001c0 R14: ffffc90012398e00 R15: 0000000000000140
+
Dec 16 07:22:13 cube kernel: [1178220.704516] FS:  00007f52b107d700(0000) GS:ffff880008480000(0000) knlGS:00000000f75858d0
+
Dec 16 07:22:13 cube kernel: [1178220.704516] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
+
Dec 16 07:22:13 cube kernel: [1178220.704516] CR2: 00000000000001c0 CR3: 00000001712a7000 CR4: 00000000000006e0
+
Dec 16 07:22:13 cube kernel: [1178220.704516] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
+
Dec 16 07:22:13 cube kernel: [1178220.704516] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
+
Dec 16 07:22:13 cube kernel: [1178220.704516] Process Xorg (pid: 7344, threadinfo ffff88003e91a000, task ffff88020bf5a350)
+
Dec 16 07:22:13 cube kernel: [1178220.704516] Stack:
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  000000001238c660 ffffffffa0389489 0000000000000100 0000000000000148
+
Dec 16 07:22:13 cube kernel: [1178220.704516] <0> 0000000000000000 0000000000000000 000002af00000068 ffffffffa038c6e7
+
Dec 16 07:22:13 cube kernel: [1178220.704516] <0> 00000000000001c0 000000000019330c 00007f52ab7a2000 ffffc9001236f620
+
Dec 16 07:22:13 cube kernel: [1178220.704516] Call Trace:
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffffa0311680>] ? _ZN3MSF9free_surfEP9CMMDriverP10CMMSurface+0x50/0xe0 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffffa030d391>] ? CMMFreeSurface+0x131/0x1b0 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffffa031d24c>] ? _Z8uCWDDEQCmjjPvjS_+0x68c/0xf00 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffffa02d2114>] ? firegl_cmmqs_CWDDE_32+0x334/0x440 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffffa02d0ba0>] ? firegl_cmmqs_CWDDE32+0x70/0x100 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffffa02d0b30>] ? firegl_cmmqs_CWDDE32+0x0/0x100 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffffa02b0b5a>] ? firegl_ioctl+0x1ea/0x250 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffff810fa4c7>] ? vfs_ioctl+0x56/0x6c
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffff810fa9e0>] ? do_vfs_ioctl+0x48d/0x4cb
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffff812fd946>] ? do_page_fault+0x2e0/0x2fc
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffff810faa6f>] ? sys_ioctl+0x51/0x70
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  [<ffffffff81010b42>] ? system_call_fastpath+0x16/0x1b
+
Dec 16 07:22:13 cube kernel: [1178220.704516] Code: 4c 8d 64 24 20 c7 44 24 04 00 00 00 00 4c 8d af 80 00 00 00 48 c7 44 24 20 00 00 00 00 48 c7 44 24 28 00 00 00 00 4c 89 6c 24 40 <49> 8b 5d 00 31 c0 48 85 db 48 89 5c 24 30 74 04 48 8b 43 30 49
+
Dec 16 07:22:13 cube kernel: [1178220.704516] RIP  [<ffffffffa030ef0f>] _ZN17SegmentMapManager13deleteMappingEP9CMMClient+0x3f/0x170 [fglrx]
+
Dec 16 07:22:13 cube kernel: [1178220.704516]  RSP <ffff88003e91bc38>
+
Dec 16 07:22:13 cube kernel: [1178220.704516] CR2: 00000000000001c0
+
Dec 16 07:22:13 cube kernel: [1178220.705883] ---[ end trace c9192c1a2722dc89 ]---
+
</pre>
+
As fglrx source is closed, it will b difficult to catch this bug without AMD internal resource. If someone from AMD read this: please catch this bug. It is there from a least the last couple of monthly driver and really make my machine unable to do the work it was intended to do. I first see this bug using a Debian Lenny AMD64 with a old kernel. I recently upgraded to Debian Squeeze AMD64 with his last kernel, but the bug is exactly the same.
+
  
 
=== An Example of a working Xorg.conf ===
 
=== An Example of a working Xorg.conf ===

Revision as of 20:13, 4 October 2011

Installer Issues

When the installer fails to produce results, check the directory where the ati catalyst installer has been placed. If it contains international characters or spaces, weird errors will arise. (The issue has been reported to ATI some time ago, but even in the newest releases they seem to like to prefer to conserve the bug)


X Server Related Issues

No high-resolution video modes available

  • Versions of the fglrx driver following 7.12 had problems with video resolutions higher than 1280 x 1024. The modes of the xorg.conf are simply ignored, and the server starts up e.g. with a resolution 1280 x 1024 (even if this resolution is not defined in xorg.conf). This is particularly a problem on LCD displays.
  • This bug documents the problem; it is fixed since driver version 8.2
  • Looks like it reappeared again some version above ati-driver-installer-8-12-x86.x86_64.run . Version ati-driver-installer-9.2-x86.x86_64.run, and ati-driver-installer-9-4-x86.x86_64.run has this bug. At least on integrated HD3200 card.

No XVideo support on 690G integrated graphic chipset

  • Upgrade your BIOS if you get random flicker lines and black screen with a 690G chip.
  • Motherboard using the 690G IGP chipset don't have XVideo support. When you execute the "xvinfo" command you get "no adaptors present". This is the case by using the 8.39.4 FGLRX driver and whenever the "sudo aticonfig --overlay-type=Xv" command or the "sudo aticonfig --overlay-type=opengl" was used. ATI seem to know this as there list TVtime as an application unable to run on a 690G chip.
  • XVideo works with 8-1 release (version 8.45.4). You need to change the defaults in /etc/ati/amdpcsdb (created by amdcccle, loaded by X on start, and saved on exit). With X shutdown, set VideoOverlay=Son, OpenGLOverlay=Soff, and Textured2D=STrue. (Don't use aticonfig or xorg.conf to set these. At this time, aticonfig and amdccle don't change these settings, and /etc/ati/amdpcsdb seems to override xorg.conf) (Verified on Asus M2A-VM with BIOS 1501)
  • With 8-3 release (8.47.1), to get XVideo working I added Option "TexturedVideo" "true" to the xorg.conf file. It wasn't necessary to edit the /etc/ati/amdpcsdb file as described in the paragraph above; the open GL overlay can be active and it will still work.

System lockup on logout or switch to virtual consoles

If your system locks up after you logout or when you try to switch to a virtual console, this might be an instance of this bug. It is likely that the problem only occurs for users with an Xorg version of at least 7.0. Probably it only affects users of DVI.

There is a workaround: Use a standard D-Sub VGA connector instead of the DVI connector.

This workaround was posted as a comment to another related bug: see here.


Unfortunately "D-sub" users (like me) have the same problem.

BigDesktop (Dual screen) doesn't work after GDM login screen

This can occur on Ubuntu Feisty Fawn & Gutsy.

System > Prefrences > Screen Resolution

Select the resolution that is a combination of both screen resolutions wide and your height.

If X crashes during login, go to a virtual console using Ctrl+Alt+F1, log in, sudo vim /etc/X11/xorg.conf, and comment out the line which looks like the following:

File: /etc/X11/xorg.conf
  Option  "DesktopSetup"  "something"

Computer Freezes while using fglrx (UMA and SIDEPORT)

If after choosing fglrx as your driver in either xorg.conf or xfree86.conf files, the computer freezes and becomes unresponsive while trying to start X this may be the solution.

Some ATI cards have the ability to run in three modes: UMA, SIDEPORT, or a combination of both. UMA mode is that one in which the video card does not use its dedicated memory, but rather uses and shares the system memory. On the other hand, SIDEPORT mode is the one in which the card uses its own dedicated memory. And finally, the third mode is a combination of the previous modes in which the card uses both the system memory and its dedicated memory.

If your computer hangs, this settings may be where the solution lies. If your computer hangs, try using either UMA by itself or a combination of both. However, if you choose the combination, make sure that the UMA one is at least 128MB. In my case, I have SIDEPORT 128MB and 128MB UMA. If I choose any less for UMA, it does not work. This is definetly not an attractive solution since it compromises your systems performance. Hopefully, this will be solved very soon.

On some systems, the BIOS screen may not offer a choice of UMA or SIDEPORT. In this case, you can try turning the amount of RAM dedicated to the video card down, from 128Mb to 64Mb for example.

On some ACER laptops (at least the TimelineX), this means that you need to set display adapter mode to DISCRETE in BIOS.

Graphical Anomalies

This was experienced with an ATI Radeon X1600 Pro 512mb:

After following instructions for both Method 1 and Method 2, whenever the Composite Extension is disabled, the display would be almost unusable, but the fglrxinfo command would display the correct information. If the Composite Extension is re-enabled the display would be usable, but fglrxinfo would report using mesa drivers.

To resolve the problem it maybe needed to lower the AGP Aperture setting in my BIOS to 128mb (or lower worked too). The AGP Aperture was initially set to 256mb. After setting the AGP Aperture to 128mb, everything worked perfectly; the Composite Extension is disabled, fglrxinfo reports the correct drivers, and direct rendering is enabled. Some systems may require setting the AGP Aperture to the highest setting (256mb or 512mb).

There's been a bug report regarding anomalies in Firefox as well.

OpenGL framebuffer Corruption

This problem has been experienced on Thinkpads (T60p) with an ATI MOBILITY FireGL V5250 running driver versions 7.12, 8.01 and 8.02. Whenever any OpenGL application is rendered, the rendered output appears "scrambled" and unreadable. This problem is not very well documented and both glxgears and fgl_glxgears display this anomaly when testing.

When Anti-Aliasing is forced, the problem resides.

A solution (tested with 8.02 on Ubuntu Gutsy) to this problem is to open the ATI/AMD Catalyst Control Center and expand the item labeled '3D' in the options tree on the left-hand side of the window. From there, select "Anti-Aliasing" and check the box which reads: "Override application setting". Apply the settings and close the control center.

For an example of this anomaly, please see this image


This solution not work on acer laptop with ATI Mobility Radeon HD 2400 XT. kepfeltoltes.hu/view/080302/atisux_www.kepfeltoltes.hu_.jpg

Blank Screen with Xorg 1.3.0

If you happen to get a blank screen on X startup and you find lines similar to those in your Xorg.log:

File: /var/log/Xorg.log
2: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(swlDalHelperValidateModeFromDAL 0x549) [...]
3: /usr/lib64/xorg/modules/drivers//fglrx_drv.so [...]
4: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit 0x8b3) [...]
 

Then you're probably using the ati-drivers with Xorg-1.3.0. If that's the case the only solution (known to me) is to use a version < 1.3.0.

Edit: I got the same problem after using the --add-pairmode argument of aticonfig (using Xorg 1.3.0). My ati mobility x300 seemes to try sending the monitor signal to the vga output (even if no monitor is connected to it). After pressing [Fn]+[F8(CRT/LCD)] the monitor signal sometimes returnes to the internal laptop monitor. By switching to a console or shutting down the X-server, the card switches back to vga...

My solution: overwriting the file /etc/ati/amdpcsdb with /etc/ati/amdpcsdb.default (sudo cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb) and restore the xorg.conf (since Xorg replaces /etc/X11/xorg.conf with a failsafe config file). Then reboot the system: fglrx should now work fine again with Xorg-1.3.0 .

Radeon GPU fan is very loud / constantly works

See bug 499 for additional information.

It seems fglrx has a bug with all X800/X850 cards causing them to heat up excessively even when not in 3D mode. This behaviour will cause the cards' fans to function on full blast continuously. There is no known fix as of driver 8.31.05 or previous. Open source "radeon" driver does not exhibit this problem.

My Ati 1650GT has the same problem.It was normal when I enter ubuntu for 1 or 2minutes,and than ,the fan became crazy..No doubt it's because the temp~

It happens too with Radeon X1800 GTO and Radeon X1900 GT.

Possible solution (at least using a Mobility Radeon X1600):

aticonfig --set-powerstate=1

To find out which powerstates your Radeon supports try:

aticonfig --lsp

System freezes after logout with GDM, KDM or XDM[1]

If you use GDM, which is the default Login Manager on Ubuntu, modify

sudo gedit /etc/gdm/gdm.conf
File: /etc/gdm/gdm.conf
AlwaysRestartServer=true

If you use KDM, which is the default Login Manager on Kubuntu, add to the [X-:*-Core] section the following

sudo kate /etc/kde3/kdm/kdmrc
File: /etc/kde3/kdm/kdmrc
TerminateServer=true

if you use xdm, add the following to

sudo gedit /etc/X11/xdm/xdm-config
File: /etc/X11/xdm/xdm-config
DisplayManager*terminateServer:	true

System freezes at startup of Fedora 7 or RHEL 5.3 after installing the driver

Turn off the Redhat Graphical boot from grub config:

Edit the grub config file located at /boot/grub/grub.conf and remove the 'rhgb' from the kernel line in order to disable the Redhat Graphical boot.

This also works for Red Hat Enterprise Linux 5.3.

System lockup on logout with catalyst 8.01 [2]

To solve this issue you need to disable atieventsd. On ubuntu you can run:

sudo /usr/sbin/update-rc.d -f atieventsd remove

Intermittent Freezes/Lockups due to AGPv3 running at 8x

Try forcing X to set AGP Speed to 4x

File: /etc/X11/xorg.conf
  Option "AGPv3Mask" "0x00000002"

((Would be nice to put down WHERE to change this, not just to change this. The same applies to just about every hint shown above.))

+ You add it to the "Device" section for your graphics card in /etc/X11/xorg.conf.

Flickering Video with Compiz enabled

Flicking video using mplayer to play movies may be caused by Compiz. Compiz is enabled by default on new Ubuntu 8.10 installs (and up).

To disable Compiz in Ubuntu:

  1. right-click on the background, select "Change Desktop Background"
  2. Select "Visual Effects" tab
  3. Select "None"

What also works, is to enable tear free desktop in config in 11.2+.

What an awesome way to explain this-now I know eevyhrting!

An Example of a working Xorg.conf

Lots of trial and error changing Options to get Compiz-Fusion running under Mandriva 2008-2010. X Server 1.6.5 (Sadly, the 'drak' tools that come with Mandriva to configure are worthless.)

In this instance it was chosen to remove packaged drivers and install from .bin file from AMD/ATI.

Most Options were added per 'aticonfig -f --initial ... ...'. And the rest were added as needed. Constantly checking '/var/log/Xorg.0.log' for errors and warnings.

 Section "ServerLayout"                     
        Identifier     "aticonfig Layout"  
        Screen      0  "aticonfig-Screen[0]-0" 0 0  # The extra zeros are necessary for some reason
        Option         "AIGLX"                    
EndSection                                        

Section "Files"
EndSection     

Section "Module"
        Load "dbe"
        Load "v4l"
        Load "extmod"
        Load "type1" 
        Load "freetype"
        Load "glx"     
        Load "dri"     
EndSection             

Section "Monitor"
        Identifier "aticonfig-Monitor[0]-0"
        Option "VendorName" "Hewlett-Packard"
        Option "ModelName" "HP D2845 Ergo 1600 21-inch Display"
        HorizSync 31.5-95.0                                    
        VertRefresh 50.0-160.0                                 
        Option      "DPMS" "true"                              
EndSection                                                     

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
        Option      "UseFastTLS" "2"
        Option      "Textured2D" "on"
        Option      "TexturedXrender" "off"
        Option      "BackingStore" "on"
        Option      "VideoOverlay" "off"
        Option      "OpenGLOverlay" "off"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "on"
        Option      "RENDER" "on" # essential for proper window border rendering
        Option      "DAMAGE" "on" # compiz-fusion calls for explicitly
EndSection

Open for scrutiny and testing.


Sticky mouse cursor

Some users reported that the mouse cursor gets stuck when the mouse is moved to the lower right corner. At least in several versions of Ubuntu using Gnome desktop and starting with Catalyst 11.4.

That seems to be solved when adding ""load "dri"" to "Section Module" of xorg.conf.

aticonfig Issues

If you get the message ‘‘aticonfig: No supported adapters detected’’, you might have a card not officially supported by the fglrx driver but that might still work when forcing the driver to load. See Ubuntu#Unsupported_adapter.

References

  1. http://ati.cchtml.com/show_bug.cgi?id=239 Going back to gdm/kdm/xdm hardlocks after running X session
  2. http://www.phoronix.com/forums/showthread.php?t=7448&page=5 System lockup on logout with catalyst 8.01


Distribution Neutral Steps

Verifying | Configuring | Troubleshooting