Difference between revisions of "Ubuntu Natty Installation Guide"

From cchtml.com
Jump to: navigation, search
(Initial page creation)
 
m (Add note on Unity)
Line 17: Line 17:
 
  $ cd ..
 
  $ cd ..
 
  $ sudo dpkg -i fglrx*.deb
 
  $ sudo dpkg -i fglrx*.deb
 +
 +
= Catalyst and Unity =
 +
At this time, Catalyst doesn't work with the new Ubuntu desktop (Unity). You can still use the classic GNOME desktop (or another desktop environment).

Revision as of 15:15, 13 January 2011

Construction Notice

Since Ubuntu Natty/11.04 is still under construction, so is this page. Until Natty is released, the Maverick guide ( http://wiki.cchtml.com/index.php/Ubuntu_Maverick_Installation_Guide ) will serve as the main source of info on ATI Catalyst. This page will only note items that are relevant to Natty, but not Maverick.

Patching Catalyst 10-12 Source

Catalyst 10-12 needs patched for compliance with kernel version 2.6.37 before you can install it.

$ cd ~/; mkdir catalyst10.12; cd catalyst10.12/
$ wget http://www2.ati.com/drivers/linux/ati-driver-installer-10-12-x86.x86_64.run
$ chmod +x ati-driver-installer-10-12-x86.x86_64.run
$ ./ati-driver-installer-10-12-x86.x86_64.run --extract driver
$ cd driver
$ wget http://ubuntuone.com/p/WVN/firegl_public.c
$ wget http://ubuntuone.com/p/WVU/Makefile
$ mv firegl_public.c common/lib/modules/fglrx/build_mod/
$ mv Makefile common/lib/modules/fglrx/build_mod/2.6.x/
$ ./ati-installer.sh 8.801 --buildpkg Ubuntu/natty
$ cd ..
$ sudo dpkg -i fglrx*.deb

Catalyst and Unity

At this time, Catalyst doesn't work with the new Ubuntu desktop (Unity). You can still use the classic GNOME desktop (or another desktop environment).