Difference between revisions of "Ubuntu Natty Installation Guide"

From cchtml.com
(Update)
(Update for fglrx 8.840)
Line 2: Line 2:
 
Since Ubuntu Natty/11.04 is still under construction, so is this page. Until Natty is released, the Maverick guide ( http://wiki.cchtml.com/index.php/Ubuntu_Maverick_Installation_Guide ) will serve as the main source of info on ATI Catalyst. This page will only note items that are relevant to Natty, but not Maverick.
 
Since Ubuntu Natty/11.04 is still under construction, so is this page. Until Natty is released, the Maverick guide ( http://wiki.cchtml.com/index.php/Ubuntu_Maverick_Installation_Guide ) will serve as the main source of info on ATI Catalyst. This page will only note items that are relevant to Natty, but not Maverick.
  
= Xserver 1.10 Incompatibility Warning =
+
= Automatic Installation =
(This section to be removed once Catalyst supports Xserver 1.10)
+
AMD has issued a special preview release of fglrx/Catalyst for use with Ubuntu Natty/11.04. You can install it using Synaptic or from the command line:
Hopefully, AMD will integrate support for the new Xserver before Natty's release. The Catalyst 11.5 beta/preview release is said to have it. --[[User:Dtl131|Dtl131]] 07:54, 30 March 2011 (UTC)
+
$ sudo apt-get install fglrx fglrx-amdcccle
For more information, see: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/709505
+
Note: the Additional Drivers/jockey app does not find the proprietary driver at this time --[[User:Dtl131|Dtl131]] 00:51, 31 March 2011 (UTC)
{| WIDTH="650" cellpadding=0 cellspacing=0 style="background-color: red; border: solid 1px #666666; color: #ffffff; text-align: center;"
+
 
| style="background-color: #666666; border: solid 1px #666666; border-bottom: 1px solid #888;" | <font size="-1">'''Major Breakage'''</font>
+
= Installing the drivers manually =
|-
+
Versions of Catalyst downloaded directly from AMD will not work on Natty/11.04 at this time. See the section above for details on using Catalyst.
| <br />WARNING: At the end of January 2011, Ubuntu integrated Xserver 1.10 into Ubuntu Natty/11.04. Even the most current release of Catalyst, 11-3, is not compatible with it, so Catalyst will not work if you have already installed Xserver 1.10. You can still use the open source driver until AMD releases a suitable version of Catalyst.<br /><br />
 
|}
 
  
 
= Catalyst and Unity =
 
= Catalyst and Unity =
 
At this time, Catalyst doesn't work with the new Ubuntu desktop (Unity). You can still use the classic GNOME desktop (or another desktop environment).
 
At this time, Catalyst doesn't work with the new Ubuntu desktop (Unity). You can still use the classic GNOME desktop (or another desktop environment).

Revision as of 00:51, 31 March 2011

Construction Notice

Since Ubuntu Natty/11.04 is still under construction, so is this page. Until Natty is released, the Maverick guide ( http://wiki.cchtml.com/index.php/Ubuntu_Maverick_Installation_Guide ) will serve as the main source of info on ATI Catalyst. This page will only note items that are relevant to Natty, but not Maverick.

Automatic Installation

AMD has issued a special preview release of fglrx/Catalyst for use with Ubuntu Natty/11.04. You can install it using Synaptic or from the command line:

$ sudo apt-get install fglrx fglrx-amdcccle

Note: the Additional Drivers/jockey app does not find the proprietary driver at this time --Dtl131 00:51, 31 March 2011 (UTC)

Installing the drivers manually

Versions of Catalyst downloaded directly from AMD will not work on Natty/11.04 at this time. See the section above for details on using Catalyst.

Catalyst and Unity

At this time, Catalyst doesn't work with the new Ubuntu desktop (Unity). You can still use the classic GNOME desktop (or another desktop environment).